HardBirch

configure: error: Bluetooth library is required

时间:09-09-25 栏目:系统技术篇 作者:鲁智森也有文化 评论:0 点击: 2,601 次

From: Mats Erik Andersson <mats.andersson64 <at> comhem.se>
Subject: Re: configure: error: Bluetooth library is required
Newsgroups: gmane.linux.bluez.user
Date: 2007-07-09 13:54:58 GMT (2 years, 11 weeks, 1 day, 1 hour and 44 minutes ago)

Dear Robert,

mån 2007-07-09 klockan 12:34 +0000 skrev Robert Rawlins:
> Thank you Mats,
>
> I ran the commands that you gave me and they appeared to run ok, and
> when i ls the /usr/local/bluetooth/ folder it displays the following
> files:
>
> bluetooth.h  bnep.h  cmtp.h  hci.h  hci_lib.h  hidp.h  l2cap.h
> rfcomm.h  sco.h  sdp.h  sdp_lib.h
>
> However, i still get this error when using the configure :-s it really
> is most odd. I notice in your last mail that you mention the static
> and shared libraries, i'm not sure if this is of any use, but here is
> a little more information from my ./configure on the utils, notice it
> says build static ... no? is that normal?
>
> checking whether to build shared libraries... yes
> checking whether to build static libraries... no
> configure: creating libtool
> checking for ppoll... no
> checking for pkg-config... no
> checking for BLUEZ... configure: error: Bluetooth library is required
>
> Thanks for all your help on this mats, I'm sure we're getting closer,
>  

Yes, first and most importantly do

   # apt-get install pkg-config

which is lacking by your printout (the line second to last). This
explains most of the present problems, since it provides a mechanism
to out locations of libraries, and then to configure source code that
depends on these libraries.

I did the following to check your prospects, likewise an Debian Etch
system, but this machine is only slowly getting to the expanded stage
where my Debian Sarge is at.

$ mkdir /tmp/blind

$ cd /tmp/bluez-libs-3.12
$ ./configure --prefix=/tmp/blind

$ make              # No errors should occur
$ make install      # You can perform a dry run using "make -n install",
		    # read the output, and se where things go.
		    # Somewhat technical output, though.

$ cd ../bluez-utils-3.12
$ ./configure --prefix=/tmp/blind --with-bluez=/tmp/blind
$ make 

This aborts with an error for device.c complaining about
LMP_PAUSE_ENC, LMP_NFLUSH_PKTS, and LMP_LSTO. The Bluez spacialist
have to take over if your machine gets stuck here, since I only
use Bluez-utils 2.25 and 3.7. But at least, when you can reach this
stage the original hurdle has been overcome, since you have a working
copy of libbluetooth2.

Just a reminder, this.so is a dynamic/shared library, whereas that.a
is a static library. Most users will never need to tell them apart.
You will soon learn when progressing further on the road of tailoring
your own software.

Best regards,	Mats E A

-------------------------------------------------------------------------
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/

声明: 本文由( 鲁智森也有文化 )原创编译,转载请保留链接: configure: error: Bluetooth library is required

configure: error: Bluetooth library is required:目前有

  1. 我在编译bluez-utils-3.36的时候也出现这个问题,configure: error: Bluetooth library is required,一直没有解决,能否帮助我一下,谢谢!我的QQ是:1597055143,麻烦注明一下

    2011-11-21 22:26 [回复]

发表评论


QQ群互动

Linux系统与内核学习群:194051772

WP建站技术学习交流群:194062106

魔豆之路QR

魔豆的Linux内核之路

魔豆的Linux内核之路

优秀工程师当看优秀书籍

优秀程序员,要看优秀书!

赞助商广告

友荐云推荐