HardBirch

Xampp安装Zend Optimizer

时间:11-12-08 栏目:系统技术篇 作者:鲁智森也有文化 评论:2 点击: 5,594 次

最近在自己的服务器上“玩耍”网站,在本地调试的时候出现提示 "Zend OPtimizer is not installed",本地机器上的XAMPP
版本还是老版本V1.6.7 Zend Optimizer是默认安装的,那为什么还会有“is not installed”的提示呢?

xamppapachebinphp.ini
  
“zend_optimizer.enable_loader = 0”,改为1即可


如果是高版本的XAMPP V1.7.4之后的,PHP5.3以上的

Xampp安装Zend Optimizer注意项

XamppPHP5.3以上支持Zend Guard Loader

其实低版本的xampp是自带Zend Optimizer插件的,只需要在php.ini里面将“zend_optimizer.enable_loader = 0”,改为1即可。而秦天SEO用的Xampp版本一开始是1.74的,为了调试就换成了最新的1.77,看了下PHP是5.3.8的,去官网下载Zend
Optimizer,发现并不支持5.3.x以后的版本。但phpvod视频点播系统网站必须要Zend才能用。看了下,zend官方的介绍,php5.3以上的版本不再支持Zend Optimizer,但是可以使用Zend Guard Loader。下载解压到任意路径,在php.ini里面最后添加如下语句即可使用:

[Zend.loader]

zend_loader.enable=1

zend_loader.disable_licensing=1

zend_loader.obfuscation_level_support=3

zend_loader.license_path=

zend_extension="c:phpextZendLoader.dll"


声明: 本文由( 鲁智森也有文化 )原创编译,转载请保留链接: Xampp安装Zend Optimizer

Xampp安装Zend Optimizer:目前有2 条留言

  1. 板凳
    hmilyzhang:

    此种添加方式无效····Zend Guard Loader无法加载····使用这种办法还是不被支持······win7 64bit ···xampp 1.74

    2011-12-29 16:23 [回复]
  2. 沙发
    do2jiang:

    [reply]hmilyzhang[/reply]
    根据提示查查环境差异看,这个操作是经过验证的~ 基本上问题不大,有问题应该是 Apache 或者 php的配置差异上。

    2012-05-17 14:20 [回复]

发表评论


QQ群互动

Linux系统与内核学习群:194051772

WP建站技术学习交流群:194062106

魔豆之路QR

魔豆的Linux内核之路

魔豆的Linux内核之路

优秀工程师当看优秀书籍

优秀程序员,要看优秀书!

赞助商广告

友荐云推荐